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Pasting Data into an Excel Worksheet

Word

Paste

F2/Paste

Copy > Paste results in the three items in the Word document taking up three cells in Excel. Click in the
desired destination cell first, press F2 to edit the cell content, and then paste. All the copied data end up
in that one cell.
Divide by Zero Errors

If the divisor is zero, the desired result should be zero, but because you cannot divide by zero, Excel
displays a divide by zero error.

The formula reads: if there is an error when dividing A1 by A2, then return a value of zero, else do the
divide and display the result.
The ISERROR function returns TRUE if the result is #DIV/0. It will also return true for #N/A, #VALUE,
#REF, #NUM, #NAME, or #NULL. The function name can be either ISERR or ISERROR.
Creating a Dropdown List
When building a worksheet for someone to enter data, it can be useful to include a dropdown list
instead of having direct entry. The dropdown limits entry to what is included in the list eliminating the
possibility of wrong entries or spelling errors.

If the entry was left open, anything could be entered into the State field (cell).
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Create a list of valid state codes

Select the cells that will use the dropdown list. Choose Data > Data Tools > Data Validation to open the
Data Validation dialog box. Click the Settings tab. Under Allow chose List. Under Source click the
selection button and choose the cells containing the valid list of state codes. Then click OK.

``
When a cell is selected ad dropdown arrow appears to the right. Click the arrow and the valid list of
codes appear. Click to select the desired state code.
Using the Built In Dropdown List
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Even without creating a dropdown list to choose from, Excel has a dropdown capability to allow easy
entry of duplicate data. Instead of entering data in a cell, right-click and choose Pick From… When you
do, a dropdown list appears with all of the previous entries. Choose one and it is place in that cell.
Entering Data with Forms

Excel 2003 included a form selection for entering data that is absent from Excel 2007. It is not totally
gone and can be added to the QAT (Quick Access Toolbar). Office > Excel Options > Customize, then
choose Commands Not in the Ribbon, locate and click on Form…, and then click the Add button to add
the Form button to the QAT.

Click OK and locate the form button.
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Select the data (row of titles for an empty data set) and then click the Form button. The data entry form
appears. Each time data is typed and New is pressed, a new row of data is added to the worksheet.
When done, click Close.
Custom Lists
Using the Fill Handle it is easy to enter days of the week, months, and other lists. It makes for quick
worksheet creation. Perhaps you have a list of store names, a list of sales territories, or a list of sales
person you have to include on many worksheets. You can type them each time, or even doing a
copy/paste from another worksheet, but there is an easier way.
Create a custom list that you can create the sequence using the Fill Handle anytime you need to include
them in your worksheet.

Office > Excel Options > Popular > Edit Custom Lists
With NEW LIST selected, type your list of items (you can also select them from a existing range of cells or
import a list). Separate each item with a comma space. When the list is completed, click Add

The list is added to the end of the list of lists. Click OK and OK to exit the dialog boxes and try out your
new list.
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Enter one of the items in the list, and then drag the Fill Handle down to generate the reset. Drop the Fill
Handle and the other entries are filled in from the list.
Adding a Spinner Control
A spinner control is another way to force users to enter the correct data in a cell. A good example might
enter number of years for a loan calculation.
To use any of the form controls built into Excel, you must have access to the Developer tab on the
ribbon. To add it click Office > Excel Options > Popular and check the box reading Show Developer tab…

The Spinner is usually placed to the right of the cell to receive the results. Select the results cell, then
Developer > Controls > Insert and click the Spinner Form Control (top row, fourth from the left)

Move the + mouse pointer to the cell you want the Spinner and draw it by dragging t draw it. You may
change the size later, but try to make it fit the height of the cell. Click off to remove the sizing handles.

To setup the Spinner, right-click it, and then click Format Control
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The current value is what you want the result cell to contain when the sheet is opened. The minimum
and maximum values limit the allowable entries. The incremental change is added (or subtracted) to the
current result as you click the up or down spinner arrow. The cell link is the address of the result cell.
The possible values are from 0 to 30000. Decimal values are not allowed.

The up arrow adds to the result making it go up in value; the down arrow goes down.
A Spinner Control with Decimals
Using a formula, we can display different increments. For example, let's setup our Spinner to select a
series of interest rates in .25% increments. Since 1 / 4 = .25, we can take the value from the Spinner and
divide it by 400 to create our percentages. Every time the spinner advances by 1, the percentage
advances by .25%.
Change the result cell to C2 and place the following formula in A2: =C2/400

As the Spinner is clicked, the value in A2 is increased or decrease by .0025. Format A2 as % using Home >
Number, pull down the arrow and clicking %.
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A Spinner Control Referencing an Array
Instead of an integer value or a calculated result, we want to spin through a series of choices.

To place the correct state code in B2, we want a Spinner Control to spin through all the possibilities. Add
a spinner to B3, then right-click the control and select Format Controls…

Since we have six states in our array of state code, out maximum value is 6. The result cell is D2 and will
contain a number from 1 to 6. We will use this value to choose the nth state code from the array. Enter
the following formula in B2: =INDEX(A1:A6,D2,1)

The INDEX function lets us pick one value from a array of values. The first argument describes the range
containing the array. The second is the cell containing the element of the array to be selected. The third
describes the column in the array to be used. Some arrays have multiple columns of data and 1=the first
column, 2=the second column, etc.
By setting the starting value at 6 and sorting the array in Z to A order, the up arrow on the spinner
causes the results to go up the alphabet and the down arrow to go down.
The Scroll Bar Control
This works like the Spinner Control. You can click the up and down arrows to advance the results, drag
the scroll bar, or click in between the bar and an arrow to advance a page at a time.
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Choose the Scroll Bar control (second row, third from the left under Form Controls). Draw it in C1 down
through C6.

Using the INDEX function, display the result in B2: =INDEX(A1:A6,D2,1)

If all you need is a series of values (like number of months or years), just make the result cell B2 and set
the minimum and maximum values to your requirements instead of indexing an array.
A Combo Box with a Two Dimensional Array
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The array contains the name of the sales person and their commission rate. We want to enter the sales
amount in E2, select the correct sales person, and have the correct rate chosen and the commission
calculated.
Format E2 and E5 as comma, and E4 and % with 2 decimals.
Enter the following formula in E5: =IF(ISERROR(E2*E4),"",E2*E4)

Choose the Combo Box control (first row, second from the left under Form Controls). Draw it in E3 over
to F3 so the dropdown arrow appears in column F.

Using the INDEX function, display the result in E4: =INDEX(A2:A6,G3,2)

Pull down the arrow and select a sales person, the correct % appears in E4 and the resulting commission
amount in E5.
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Using a List Box

A List Box works like the other form controls. It display the list of items in a scrollable form. Locate the
one desired and click it to generate the index value—the sequence number of the item in the selected
array.

Add a list box to E1. It is the second from the right on the first row of the Form Controls.

In D7 enter =INDEX(A1:B10,D2,2)
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Scroll down the list. When a state name is selected, the Postal Code appears in D7.
Using a Check Box
A check box results in one of two states. Checked is TRUE and unchecked FALSE. Using some logic, this
can be turned into values or other text entries.

Choose the Check Box control (first row, third from the left under Form Controls). Draw it in B2 over to
D2. Select and replace the words with "Click for True". Align the control so the check box is within the
cell, then right click and select Format Control.

Enter the cell address for the result (TRUE or FALSE)

Click and the checkmark appears giving a TRUE result, click again to remove the checkmark giving a
FALSE result.
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If you need other result, like 0 for FALSE and 1 for TRUE, use a formula. In A3 enter the following:
=IF(A2=TRUE,1,0). Notice there are no quote around the word TRUE. This is because TRUE is a Boolean
value, an on or off condition, and not the actual word true.
Using Option Buttons
Option buttons (also referred to a radio buttons) work like check boxes in that they return a value if
clicked. Instead of a TRUE/FALSE value, they return a number. They are usually used to select between
multiple options. Grouped in a Group Box, when one button is selected, the others turn off. The result is
a value from 1 to n with n being the last option button. If there were 5 buttons the results would range
from 1 to 5. The Group Box is not necessary if you are only going to have one set of buttons, that is only
one button is to be on for the sheet. For multiple sets of buttons, each set must be placed inside a group
box.

Choose the Option Button control (first row, last on the right under Form Controls). Draw it in B2. Select
and replace the words with "Male". Align the control so the check box is within the cell, then right click
and select Format Control.

Checked causes the button to appear with a black dot in it. Make the result cell A2.
Next, create a second button in C2. Name it Female. Have it unchecked but refer to the same cell as the
result field.
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When the first button is selected, the result is 1. When the second is selected, it is 2. If we have 5
buttons, only one could be on at a time and the value would indicate which is on.

The Group Box in on the second row, first on the left. Place it first, rename it to describe the reason for
the options, and then fill in the options.

Add a second Group and options. Only one button can be selected per group. Each group needs to have
a different result cell.
Counting Some of the Cells
We use the function COUNT to determine how many numeric entries are in a range of cells. For nonnumeric entries, we use COUNTA. Buy, what if we want to determine how many entries in a range of
cells contains a certain value?

In this case, we want to know how many entries are RI and how many are CT. In C1 enter the following
formula: =COUNTIF(A1:A7,"RI") and in C2 enter: =COUNTIF(A1:A7,"CT")
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Notice that the lower case entry in A5 is counted. Case is ignored with the COUNTIF function. Using the
formula =COUNTIF(A1:A7,"<>CT") would also work to count the number of RI's. <> means not equal.
To SUM or not to SUM
Perhaps we want to add up (or sum) a range of cells only IF a certain condition is met. The SUMIF
function is made just for this situation.

In B5 enter the following formula: =SUMIF(A1:A4,"yes",B1:B4)
Based on the entries in the first range, the sum added up only those meeting the criteria—in this case
the word "yes". Like with COUNTIF, case does not matter. Only the cells adjacent to the "yes" ones are
included in the result.

The same range can be entered on both sides of the condition. In this case the range is A1:A5 and the
following formula is placed in A5: =SUMIF(A1:A4,">10",A1:A4). Every cell in the range containing a value
greater than 10 is included in the result.
Displaying Fractions

Entering a fraction like1/2 in a cell cause Excel to treat it as a date in the current year. This makes
entering dates an easy task, but make entering real fractions a challenge.
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Reformatting the cell as a Fraction using Home > Number, pull down the arrow and select fraction. Then
enter the fraction. You MUST format first then enter the data. If you enter the data first, Excel converts
it to date code for that date and no amount of formatting can change it back.

You can also enter the fraction preceded with a single quote to force Excel to treat it as text. However,
this keeps it a pure text and does not allow you to use it in a formula. Using the Fraction format keeps
the cell as a value that can be used in a formula.
Date Calculation Overview
Programmers use the term "Julian Date" to mean any serial date integer from any arbitrary beginning,
but usually from the beginning of a particular year. The Excel date code uses 1/1/1900 as the starting
date.
When calculating the number of years between two dates in Excel, it is typical for one to compute the
difference in days between the dates and divide the result by 365.25. However, the actual mean time
for one year is around 365.2422 days. So the question is how can our calendar stay in sync with the
seasons when one year is just slightly more than 365 days long?
The Julian calendar became official in 46 B.C. It replaced calendars using a uniform 365 days per year,
which resulted in an error of almost six hours per year. The Julian calendar corrected most of the
problem because it provides for a leap year with an extra day every four years, or an average of 365.25
days per year. This still creates an error of eleven minutes per year. So by 1582 A.D., the Julian calendar
had become out of step with the seasons by ten days.
In October 1582, Pope Gregory XIII ordered that ten days be subtracted from the calendar and came up
with the calculation that is used today which does not include a leap day in a year divisible by 100 but
not divisible by 400. The year 2000 was the first time the third rule, that every fourth century (1600,
2000, 2400) divisible by 100 is a leap year.
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The modern leap year calculation was placed into law by an act of the British Parliament in the Calendar
Act of 1751. By then, another eleven days had to be dropped, so the day after September 2, 1752 was
September 14, 1752.
Because of these adjustments made over the years, if you ever need to calculate dates far into the past,
these fundamental shifts have to be taken into consideration.
In Excel, the DATEDIF function can be used to accurately calculate the number of days, month, and years
between two dates. This is a hidden function with the following syntax:
=DATEDIF(start_date,end_date,"code")
The start date must be less than the end date and not less than 1/1/1900. If a date less than
this is entered, the function will assume 1/1/1900 as the start date
The end date could be today's date using the now() function.
The code must be in quotes:
"y"=years
"m"=months
"d"=days
Age Calculation
How old are you? Subtracting your birth date from today's date results in the number of days between
the two dates. Since there are 365 days in a year, you might think you can just divided the number of
days by 365 to get the correct answer. Well it will be close, but not correct. Every 4 years is a leap year
(we will not discuss the end of century issues) so it works better to divide by 365.25. However, even that
is not totally accurate.
Note: Excel can only do date arithmetic on date from 1/1/1900 on. Prior dates are not converted to a
date code (Julian date).

Notice we used the TODAY function to arrive at the current date. Subtract the DOB from Today to get
the number of days difference.

Instead, let's try the DATEDIF function.
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The first argument is the starting date, the second the ending date, and the third the desired results.
Y=years. M=months. D=days. This function is NOT found in the function list in Excel 2007.
Two Way Lookups
VLOOKUP and HLOOKUP are great ways to search an array of data in Excel either vertically or
horizontally.

What if the search needs to look through more than on array? This example has the user enter the
quarter number and the year. The result should be the correct amount from the above data table.

=VLOOKUP("Qtr "&B7,A2:D5,MATCH(B8,A1:D1),FALSE)
"Qtr "&B7 concatenates "Qtr " with the quarter number entered in B7 so the entire label does not have
to be keyed each time.
The VLOOKUP is in the first column of the range from A2:D5. The result is data in the other three
columns. The MATCH function is used to determine which of those three columns are to be used.
MATCH take the first argument and looks it up in the range specified in the second. FALSE tells it to find
an exact match. The result it a number indicating the relative position of the match (1-4 in this case).
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Named Ranges
Instead of describing cells or ranges of cells using their cell references, you can assign a name to them.

To sum the sales numbers in A2:A8 we can use the SUM function in A9: =SUM(A2:A8). By naming the
range as SALES, we could simply enter =SUM(SALES). It does not work any faster or better, but it makes
understanding formula easier.

Select A2:A8, then right-click and select Name a Range.

Give your range a name and click OK. As you enter the SUM function, notice sales is one of the available
entries. Press Tab and Enter to complete the formula.
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Even naming single cells can make formula easier to understand.

Name B1 Miles_Driven and B2 Gallons_Used. Notice that the name is automatically filled in from the
labels to the left of the cell being named. Then in B3 enter the formula to calculate miles per gallon
(MPG) as =Miles_Driven/Gallons_Used
Auto Fit Column Width

If we double click A|B, column A will take on the width of the widest data in A, which is the title in A1.
What we want is the widest not including A1.
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Select the data to used, then Home > Cells > Format > AutoFit Column Width.
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